Är det bra att installera plugin som inte testats med den senaste versionen av WordPress?

När vi söker efter plugin på WordPress egen webbplats, wordpress.org, brukar det stå angivet dels när det uppdaterades sist och dels om det testats med den senaste versionen av wordpress eller vilken version som nu är installerad. När det gäller uppdateringar av plugin är det, ur säkerhetssynpunkt, viktigt att försäkra sig om att det uppdaterats av tillverkaren under de senaste månaderna. I annat fall kan det finnas säkerhetsluckor som kan fungera som ingång för hackers.

Om pluginet testats för olika versioner av WordPress är inte av lika stor betydelse som om det uppdateras kontinuerligt. De plugin som kan laddas ned via WordPress egen webbplats är fria vilket innebär att personer som tillverkat pluginen gjort det ideellt och därför inte fått betalt för sitt arbete. Av den anledningen händer det ibland att man stöter på plugin som inte testats för den aktuella versionen av WordPress. Men betyder att det inte finns något hinder för att installera pluginet och själv testa det på den egna WordPress-versionen. Fungerar det inte så är det bara att avinstallera det igen och fungerar det är det bra att tala om det för andra.

​För några dagar sedan installerade jag pluginet Sucuri Security från WordPress egen sida. Det är ett plugin som  används för att bland annat göra skanningar för att upptäcka intrång och svartlistning. Detta plugin var inte testat för den senaste versionen av WordPress men jag installerade det och det fungerar utan problem. Tveka alltså inte att installera plugin av den anledningen. Är det däremot länge sedan tillverkarna uppdaterade det bör man dra öronen åt sig och leta efter ett annat plugin.

Inlägget är skrivet av Elisabeth Svensson.